Yank Widget 1.2.1

So I didn’t make a post for the updated Yank Widget release. That wasn’t nice or very smart.

Yank Widget 1.2.1 is only a bug fix release for WordPress 2.7.x to remove errors on post and page edit screens. Please report any issues you have here or use the contact us form.

My apologies to the folks using my goofy plugins. I may have moved your comment or reply to the proper article.

7 thoughts on “Yank Widget 1.2.1

  1. Excellent plug-in! I originally tried to use Side Content plugin, but it caused some random sidebar issues with WP 2.7.

    Turns out, though, I’m having some problems with Yank Widget as well…

    1. The “Using Yank Widget” page is entitled “Using WP Super Edit”. Now I’m compelled to install WP Super Edit.

    2. Paragraph formatting isn’t applied properly to the Yanked posts. To fix this, I inserted the following lines in yank-widget.php after line 120:

    $yanked_widget_content = apply_filters(‘the_content’, $yanked_widget_content);
    $yanked_widget_content = str_replace(‘]]>’, ‘]]>’, $yanked_widget_content);

    (Line 103 seems to be missing some quotes within the brackets. I don’t know if it matters.)

    3. In the Loop, when I put get_sidebar() BEFORE get_content(), 2 instances of Yanked content get generated — one in the widget where it should be, and one replacing the actual page content. I can’t figure this one out. Isn’t that what $post_temp is for?

    1. Got it!

      I’ll be working on moving Yank Widget to WordPress 2.8. A couple of experiments on other projects might help this ugly hacked thing.

      I swear someday I will sit down and build a better interface for it. It’s so odd and confusing my users are scared of it.

      1. The interface, it ain’t too bad! Gets the job done. It works and isn’t as convoluted as the alternatives (Side Content). Oh yeah, I do have a general caveat regarding Yank, and possibly other widgets…

        If you’re using a custom sidebar style in functions.php and have removed the ‘id=”%1$s” class=”%2$s”‘ strings from the tags, the Yank Widget ID and class won’t work correctly.

        (Took me hours to figure out. I thought it was a bug I found till I realized what I did! Alcohol helped.)

        BTW, I’m still trying to get Yank working with WP 2.7! Some creative hacks may be in order…

    2. When I appled your patch I got this result..

      This plugin has been deactivated because your changes resulted in a fatal error.

      Parse error: syntax error, unexpected ‘]’ in /hermes/web09/b1076/pow.mndowning/htdocs/wp-content/plugins/yank-widget/yank-widget.php on line 122

      I probably missed something obvious to a php programer, but I really do not know php, I do know html.

      I like this plugin, but it does not preserve and

  2. I love this widget, thanks so much for creating it!

    I’m seeing an error on WP 2.8.1 (and 2.8.2) with Yank 1.2.1 where, after a clean installation of both, clicking on the Yank Widget link in the Settings panel returns a page that says “You do not have sufficient permissions to access this page.”

    This shouldn’t be the case because I’m the Admin user (and the only user in the system). Any idea what might cause this?

    (Note: this problem doesn’t occur in WP 2.8.0)

  3. Yank is a great widget. I upgraded to WP 2.8.3 and when I go to Yank Widgets under settings, I get a blank page with you do not have sufficient permissions to access this page. I hope you can fix this soon. Thanks very much.

Leave a Reply

Your email address will not be published. Required fields are marked *