WP Super Edit 2.1

This is a minor, yet major update for WP Super Edit. Mostly this version fixes a nasty oversight on my part and updates the plugin for better compatibility with the upcoming release of WordPress 2.7.

I also added Font Tools as WP Super Edit plugin instead of adding the Font Face and Font Size drop down menus to the basic list of TinyMCE options. After you update WP Super Edit, you can use the Rescan tinymce_plugins Folder option and have access to the Font Tools plugin. I have to keep this one separate so I can keep those menus out reach for my users.

I had to change the TinyMCE settings scanning that is done during installation since WordPress 2.7 changes the editor initialization. It really should not matter too much, and it is mostly designed as a method to capture other TinyMCE plugins that might be installed. Someday I would love to make it possible to add options to control the editor options added by other plugins, but that will be really complicated for sure.

Please feel free to leave any issues as a comment here.

31 thoughts on “WP Super Edit 2.1

  1. I did the WP Super edit install and activeted the plugin and did all the install stuff and it says it is installed but when i got to the editer i do not see any new items?

    Any help on this
    I want to be able to use tables for laying out things easy.
    Thanks

  2. Hi,

    I just started the installation, unzipped the package, put it in the plugins folder, went to the plugin admin page, clicked “activate” for WP Super edit, and I got an error message:

    “Warning: require_once(WP_PLUGIN_DIR/wp-super-edit/wp-super-edit.core.class.php) [function.require-once]: failed to open stream: No such file or directory in /mnt/vol1/home/d/e/desire/public_html/blog/wp-content/plugins/wp-super-edit/wp-super-edit.php on line 50”

    The wp-super-edit.php IS there – I checked it.

    Permissions issue?

  3. Nick, hmmm. I need to look at that. I know I should probably replace the global constants with appropriate WordPress functions.

    You should provide the WordPress version you are using. Any other particulars you may have (ie Windows server).

  4. Help! I downloaded and installed Super Edit, but on that initial install screen it’s hanging on “Please wait while we check your editor settings!”.

    I figure it shouldn’t take more than a few seconds to work that stuff out, what’s up? Did I not change the properties of some files that I was supposed to?

  5. I have just upgraded to WP 2.7.1 and whoops Super Edit has disappeared (though it’s still activated!). I tried de-activating and re-activating – no change – just the bog-standard set of tools.

  6. Nice Plugin, thank you! I’ve tested to copy a WordPress-Installation to another domain, but the WP-Super-Edit crashes and my TinyMCE is not visible. After Reinstallation von WP-Super-Edit it works. It would be nice to have an configuration export/import! Just an idea

    1. Just to say… Even though it’s been a while and it may be in place now (still searching) I too would adore either an import/export function…

      Or, a quick line about where the code is kept (if it’s not a database field) and I would happily just FTP it over. (‘course, I’ll look for that next πŸ˜‰

  7. How long is it supposed to take for the plug in to “check editor settings?” I tried clicking that part of the installation, and after 15, 20 minutes it was still stuck on “Please wait while we check your editor settings!” with nothing changing, so I gave up. Did I not wait long enough or was it hung up? And if it was hung up, what do I do now?

  8. Hi There

    I’m getting this…

    “WP Super Edit

    To give you more control over the WordPress TinyMCE WYSIWYG Visual Editor. For more information, visit the WP Super Edit project. You can help continue development by making a donation or other contribution.
    Click here to start the WP Super Edit installation by scanning your editor settings.
    Please wait while we check your editor settings!”

    For how long time do I have to wait? 5-10-20 min? Nothing are happening.

    Thomas

  9. Frackin’ editor scan and database move issues!

    I am really sorry I’ve been so busy lately and WP Super Edit really needs some optimization and clean up love for sure. I’m going to add the scan issue and database moving issues to the known issue list and hopefully I can start pulling apart the quickly coded pieces and make things work better soon.

    Please include any WordPress version and Server information you can about your problems. I may be able replicate some things on the systems I have access to.

    For the scan problems; Log into your WordPress site and take a shot* with with following URL:

    http://(my wordpress site)/?scan=wp_super_edit_tinymce_scan

    *Drink responsibly!

    You should get a blank page with “Complete”. The original idea was to try to capture the tinyMCE WordPress settings and use them for default settings, but I may need to change the approach if this stupid bug is being such a problem!

    1. Sorry, I tried this, I get the “complete” page, but I still cannot adjust Super-edit settings. Insists on scanning.

    2. Hi,

      We are having the same issue with this plugin on wp 2.7.1. Works fine on 2.7. Starts the scan and simply freezes. Tried http://(my wordpress site)/?scan=wp_super_edit_tinymce_scan but I’m not sure what this is meant to do as the result is the same.

      We are using MySQL 5.0.51a & PHP 5.2.9.

      Bummer really as we really love this plugin. Any work arounds?

  10. I activated the plugin, it scanned the settings fine, run the install and get following:

    Warning: Invalid argument supplied for foreach() in D:\Apache2.2\htdocs\wp-content\plugins\wp-super-edit\wp-super-edit.php on line 77

  11. I did the scan with the URL you listed (with WP-S-E already activated, don’t know if I should have deactivated it first or not), and I got the “complete” screen. Went to the Dashboard and tried to start using it, but got the same “Click here so we can scan your settings” screen again.

    I decided to try deactivating the plugin and then try the scan again. I deactivated, then used the URL like before and this time all I got was my own home page. Activated the plugin just to see, and yeah, we were back to the “we have to scan your settings” screen again.

    *Sigh.* I’d really like to try this plugin – it’d solve mucho problems for me! PS: I’m using WP 2.7, and Earthlink hosting (which was not my choice).

  12. My first try didnt worked. It was an url conflict. If you use custom apache url rewrite rules, it can help you, you must to change 2 lines to work with browser url schema instead of server file system one :

    wp-super-edit.core.class.php, line 82 :

    $_SERVER[‘PHP_SELF’] -> preg_replace (‘/\?.*$/’, ”, $_SERVER [‘REQUEST_URI’])

  13. hi, i tried to use it (again) with wordpress 2.7.1 but i got this:
    Warning: Invalid argument supplied for foreach() in ..\wp-content\plugins\wp-super-edit\wp-super-edit.php on line 77

    and instead buttons this for each:
    Warning: in_array(): Wrong datatype for second argument in ..\wp-content\plugins\wp-super-edit\wp-super-edit.admin.class.php on line 1129

    what does this mean?

    1. It seems that PHP 5 is required for WP Super Edit to work. I upgraded the host’s configuration to allow both PHP 4 and 5, and everything seems to be working fine.

  14. I too am experiencing the issue of Super-edit hanging whilst scanning my editor settings. This has rendered Super-edit 100% unusable.

  15. Sorry about the late reply y’all. WP Super Edit 2.2 should be out real soon for WordPress 2.8.

    I have my doubts that a new version will work well for older versions of WordPress since I have keep track of WordPress versions and versions of the TinyMCE editor.

    I am incredibly sorry that recent comments didn’t get to my inbox because I may not have time to go back for testing issues with WordPress 2.7.1. I haven’t had issues with the WordPress 2.7 sites I maintain (PHP5 and PHP4) and I didn’t see the recent comments till today. πŸ™

  16. Hi, I tried to install WP Super Edit 2.2. in WP 2.8, but it hangs while scanning my editor settings. πŸ™ My hosts configuration allows PHP 5, so I have no idea what’s the problem.

  17. I want to install WP uper Edit 2.2. in WP 2.8.
    I placed the plugin in the plugin folder. Than i follow the instructions in the adminitratir pannel. After a while I see a white screen and nothing happens? What do i have to do now??

  18. Hi, i’ve got the “Please wait while we check your editor settings! ” window showing forever too. The apache error.log says: :Directory index forbidden by rule” when the checking is done. So i think Super Edit needs a “Options All” in the apache vhost.conf. Unfortunately i cant reach this file on the particular server where i want to install WP super edit.

  19. have installed WP Super Edit on several client sites and am having some issues with this one. keep getting:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in …/wp-content/plugins/wp-super-edit/wp-super-edit-admin.php on line 1298

    using
    PHP version:5.2.9
    Apache version 2.2.13 (Unix)
    MySQL version 5.0.81
    WP 2.8.4 then upgraded to wp 2.8.5 (same results)

  20. How long is it supposed to take for the plug in to β€œcheck editor settings?” And if it was hung up, what do I do now?

  21. I just installed the latest version on WP 3.5.1 and it’s working great. I have one question… is it possible for me to add additional font? They are in the .ttf format.

    Thanks in advance.

Leave a Reply

Your email address will not be published. Required fields are marked *